News

Hai un dispositivo Apple e quando navighi ti appare un messaggio di "Connessione non sicura"?

La causa potrebbe essere un vecchio certificato scaduto. Vediamo come risolvere.

Da ottobre 2021 molti utenti con dispositivi Apple meno recenti hanno riscontrato problemi di navigazione verso alcuni siti web.

Cosa è successo?

  1. il 30 settembre 2021 è scaduto il certificato Root di Let's Encrypt ed è stato sostituito da una nuova versione (ISRG Root X1) diversa dalla precedente (R3 DST Root CA X3);
  2. i sistemi macOS vecchi continuano a fare affidamento sulla vecchia versione "R3 > DST Root CA X3" anche se questo certificato non è più utilizzato dal server.

Di conseguenza, i sistemi meno recenti non riconoscono il nuovo certificato perché non ce l'hanno installato di default, è necessario installarlo manualmente.

Come risolvere?

  1. Scarica il certificato di Let's Encrypt. La lista completa dei certificati è disponibile sul sito di Let's Encrypt;
  2. Apri "Accesso Portachiavi" oppure clicca due volte sul file scaricato, si aprirà il portachiavi;
  3. Scegli di installare il certificato nel portachiavi "Sistema", potrebbe chiederti la password di amministratore;
  4. Nel Portachiavi, in alto a destra trovi la barra di ricerca, cerca ISRG, e apparirà nei risultati il certificato appena installato, "ISRG Root X1"
  5. Clicca due volte sul certificato, poi apri la tendina "Autorizza" e scegli "Fidati sempre". Ti chiederà di nuovo la password di amministratore.
  6. Chiudi il browser e riaprilo, ora dovresti riuscire a collegarti ai siti che prima non funzionavano